[WordPress] Contact Form DB:Fatal error: Declaration of CFDBShortCodeSavePostData::handleShortcode() must be compatible with that of ShortCodeLoader::handleShortcode() in …

  • このエントリーをはてなブックマークに追加
  • Pocket

attention この記事は2年以上前の投稿になります。
記載された情報が古くなっている可能性がございますので十分ご注意ください。

オンラインアップデートで、v2.8.4 にアップデートしたら下記のエラーでサイト自体が開かなくなった・・・(泣
実施した復旧手順を下記にまとめておきます。

  1. FTPにて「Contact Form DB」のディレクトリ(contact-form-7-to-database-extension)を削除
    ※サイト復旧が最優先ということで(この時点でサイトは復旧)
  2. 過去バージョン(v2.8.3)をダウンロード
    http://wordpress.org/plugins/contact-form-7-to-database-extension/developers/
  3. 管理ページにログインしてダウンロードした旧バージョンのファイルを[新規追加]→[アップロード]でインストール
  4. 「Contact Form DB」の復旧を確認

これだからオンラインアップデートって怖いですよね。。。詳しくない方は非常に困るのではないでしょうか。
もちろん、すぐさまフォーラムに報告上がってますから、作者さんがすぐに修正版をアップされると思います。
https://wordpress.org/support/topic/after-update-to-v284-get-error-message-trying-to-activate

◎追記:2014/08/07
既に修正版がアップロードされており、このエラーは発生いたしません。

ネット集客を加速させるWebサイトをWordPressで作る方法
WordPress対応 PHPファイル 難読化ツール

ご訪問ありがとうございます。
参考になりましたら『いいね!』もお願いします。

ITの活用情報を毎週お届けする無料メルマガに是非ご登録ください。

閉じる

ご意見・ご感想をお待ちしております。

いただいた情報は一般公開されません。(入力いただいたメールアドレスにてご返信させていただきます)
また、* が付いている欄は必須項目となりますので、必ずご記入をお願いします。

内容に問題なければ、下記の「コメントを送信する」ボタンを押してください。